How to install Plastic SCM 4.0 without system requirements restrictions

Wednesday, November 30, 2011 0 Comments

Hi, all:

As you might already know, Plastic SCM 4.0 comes with SQLServer CE 4.0 as the default backend in Windows. We decided to replace our good-old friend Firebird with this one to avoid undesired collisions with existing Plastic SCM 3.0 installations, since Plastic SCM 4.0 uses a different database schema that is not directly upgradeable.

On the other hand, Plastic SCM 4.0 minimum software requirements have been lifted to meet those of SQLServer CE 4.0 (check this link: http://www.microsoft.com/download/en/details.aspx?id=17876#system-requirements), which is a bit annoying, specially if you will customize your db.conf file to use a different backend after the installation / upgrade process.

Strictly speaking, Plastic SCM 4.0 requirements still are .NET Framework 2.0 SP2 for the server and .NET Framework 2.0 for the client (we finally moved our client to .NET Framework 2.0, hurray!), so if you want to avoid all the system requirements just open a CMD console (or shell in Linux) and type the following in a single line:

PlasticSCM-4.0.xxx.yyy-windows-installer.exe --nocheckrequirements true

where xxx.yyy is the release number you are trying to install. Please, take into account that if the system requirements are not met, Plastic SCM may not work correctly.

Thanks for reading and enjoy Plastic SCM 4.

0 comentarios: